Posted on Leave a comment

First release bug identified

As with any new project, there are bumps in the road. Pyr0-Piezo just hit it’s first. One of our beta testers identified a bug that causes settings sent over I2C to reset the EEPROM, thus resetting everything to defaults when the sensor is power cycled. This appears to only be the case for I2C input and not UART, however the sensor was designed to work with I2C during normal operation so we’re taking this very seriously.

If you’ve already purchased your sensor, we’ll work with you to either get its firmware updated, or we’ll send you a replacement.

If yours hasn’t been shipped yet, we’ll make sure to apply the new firmware fix before shipment, but that might delay it getting out the door by a day or two.

I’ll be working to update all of the remaining stock of sensors so that there should be no delay in future shipments.

Thank you all for your understanding and patience!

For those interested, here’s the fix for the bug

Posted on Leave a comment

Shipping Fixed! Launch Sale starts now!

The shipping system has been updated with all available carriers I can get at the moment, and as an extra treat, I’m doing a Launch Sale! Until the end of August, you can get $5 off the EasyPiezi, and $2 off each extra SingleDisk Adapter. Not only that, but I’m also offering Free Shipping on orders $50+ for Domestic and $75+ for International. Come on down to the Shop and grab yours today!

Posted on Leave a comment

They’re In!

The v2.3.0 production EasyPiezi boards, along with the SingleDisk Adapter boards have arrived at last!

As this was my first full-assembly order from the factory, there were a couple of wrinkles (which should be rectified in v2.3.1). Thankfully most of the issues were cosmetic, and only one effects the functionality of an “optional extra feature”

  • Black Soldermask Finish is Gloss instead of Matte (cosmetic)
  • A 1.5K Ω resistor was installed in place of what was supposed to be a 0Ω jumper in-line with the PT100 analog output signal (Optional feature impairment)
  • Unrelated to the boards, but some of the wiring harnesses I ordered have pinouts rearranged slightly (easy to fix but annoying)

So not too bad for a first try!

My solution to the functionality issue is that I’ll add a checkbox to the shop page, and if anyone really needs that PT100 analog input, they can check that box, and I’ll fix the jumper by hand before shipping.

Next on the ToDo:

  • Set up actual shipping rate API’s
  • Add kit options (Delta/underbed cable harnesses, printer-specific parts, etc)
  • Migrate the website over to the new server (going from 4-core up to 16-core)
  • Finish writing documentation (will be a long process)